Vodafone Sure Signal – Not!!!

This story has a happy ending so do read to the end if you are interested! – Jim

Recently I have been affected buy poor mobile phone signal quality at my home address! I am a Vodafone user and I became aware of Vodafone’s new device called Sure Signal! This device connects to your broadband router and established a G3 cell in you home which claims to support a 50M range. You can register the phone ( up to 5 ) which can connect to the device using G3 – excellent I thought!!!!.

I visited the Vodafone shop and purchased the unit which retails at £160 but is on offer at £50. I was hopeful that my poor signal strength problem was about to be resolved.

I carefully followed the instructions to register the device and then I connected it to my BT home hub. The instructions state that you need to give the device about 1 hour to connect to the Vodafone network and then it will be possible to have you mobile phone connect using G3.

After 1 hour – no sign of the device becoming active – it still has two flashing lights which seems to indicate that it cannot establish the connection to the Vodafone network. After a call to the Sure Signal support desk I am told that you need to open some pinholes in the BT firewall which I proceed to do. I wait another hour still no joy. I contact Vodafone again – apparently it can take up to 1 day for the device to register!!!!! So I wait again…….

After 24 hours still no connection…..

To curtail what is essentially a very long story involving repeated calls to both BT and Vodafone the device is still not working. I am told by BT that that have seen a lot of problems with this device and in some cases it will start to work for no apparent reason. The Vodafone forums have a lot of contributions from unhappy users.

My latest call to Vodafone and through escalation to level 2 support they now say that the device needs a certain basic level of connectivity to work. – but my broadband speed seems to be OK at 5.7Mbps and 300k up link and the latency seems also to be OK!

So it seems that this miracle cure to mobile phone signal black spots is not the reliable solution that it would claim to be! This is the worst possible position to be in being passed between the Vodafone and also BT help desks with both claiming that the problem is not theirs!!! I would really like to get this device working but it has already consumed more time that I can afford to invest – if the position improves I will update this post!!!!

Update 10/09/2010
Did a speed test this morning – see here


as you can see I have 6.29 Mbps down stream and 0.37 Mbps upstream! and the Vodaphone Sure Signal is still not working!!!!! These bandwidth levels seem to be adequate.
I plan to try one more time with the Vodafone and BT help lines today but it is not looking good I have to say!!!! One critical problem here is that the Vodafone people do not seem to have much control over the device!!! Their diagnostics are elementary and ineffective so far!

20th Sept 2010:
Vodafone have now admitted that the device is faulty and said I should take it back to the Vodafone shop to get it exchanged for another device. Aberdeen shop does not have one in stock!!!!! Frustrating or what!!!!

30th Sept 2010:
I have been travelling this week – but I was able to exchange the apparently faulty Vodafone SureSignal device. When I arrived home today I decided to try to setup the new device. If I am honest I was not feeling very hopeful that it was going to work. I went online and registered the serial number – this was easy and routine. Vodafone say you need to wait up to 24 hours for the device to come alive!!!! Now I had spent so much time setting up the firewall on my BT broadband router that I really expect that I would need to repeat this again for the new device. I was astounded after about 15 – 20 mins to see that there were first two solid light visible and then 3 solid light visible. This had never happened with the old device. So I turned to my mobile phone which is not showing 5 bars signal strength and also 3G – fantastic….. I have now made some calls with the phone and I am happy to report that it works anywhere in the house and had a the full 5 bars anywhere I do. So now I really to feel satisfied with the device and hope that it will continue to work reliably. The call quality it crystal clear and the internet performance is very fast.

Did I record the amount of time and the number of calls I had to make to BT and Vodafone to get to this stage? No alas I did not!!! But the bottom line is that I had to get used to the fact that these support lines are clearly understaffed because I never once was able to get through with having to wait at least 10 minutes in a queue listening to fairly pleasant music being played. However, I guess that “all is well that ends well” for now at least I am a happy customer.

One last thought – if I had not been IT literate and slightly technically minded I would have given up this quest some weeks ago. The bottom line is that there is a tendency for the two companies involved here to seek to apportion to blame on the other!!!!!! I was there many times in the last three weeks or so….. The capability that Vodafone have to manage this device is in my mind limited to say the least – I don’t think that thy actually know whether the devise if communicating with their head end servers or not! They will and do know if you have registered the device through their website but they seem to have know clue about the current state of health of the device when it is operating. They do not even know if it has established a connection (VPN) with the head end servers and that seems to be unacceptable and very inefficient. This seems to me to be somewhat lacking for a solution that is being marketed throughout the country!

This said I must report that the help desk technicians for both BT and Vodafone were on the whole

courteous and helpful at all stages of this rather interesting/frustrating process.

Now I need to configure the device to support other Vodafone user who frequent our address and suffer from the same poor signal issues I have had these past few months.